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Introduction
Welcome to the Agilent VEE family! Agilent Visual Engineering 
Environment (VEE) is a powerful visual language environment that 
dramatically reduces your development time. To get you started 
quickly on Agilent VEE, we have prepared this guide to show you how 
to install and use your new software. This guide also contains two 
tutorials that show you how to communicate with an instrument via 
the USB interface, and how to generate and display a waveform from 
a virtual source.

Installing Agilent IO Libraries
The Agilent IO Libraries Suite software is included when you 
purchase Agilent VEE. This software enables you to communicate 
with instruments via serial, USB, GPIB or LAN interfaces. 

You are required to install the Agilent IO Libraries Suite 15.0 before 
installing Agilent VEE if you need to communicate with instruments 
using Agilent VEE. However, you can choose not to install the Agilent 
IO Libraries Suite if you do not use instruments. 

Follow these simple installation steps:

1 Insert Agilent IO Libraries Suite CD into the CD- ROM drive. Click 
Click Here to Install Now in the Agilent IO Libraries Suite 15.0 window 
to begin installation.
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2 The InstallShield® Wizard will guide you through the installation 
process. Click Next to accept the default settings and complete the 
installation.

3 The Agilent Connection Expert Welcome Screen window will 
appear. This application configures the instruments that are 
connected to your PC. You may close this window before 
proceeding to the next step.
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Installing Agilent VEE Pro or Agilent VEE Express
1 Insert the Agilent VEE installation CD and click Install Agilent VEE Pro 

9.0 or Install Agilent VEE Express 9.0. The InstallShield® Wizard will 
guide you through the installation process. 

In regard to the differences of these products, refer to Page 19.

2 The InstallShield® Wizard will check if Agilent IO Libraries Suite 
15.0 is installed. If it is not, the following message box will appear.

Please note that Agilent IO Libraries Suite 15.0 is a prerequisite if 
you communicate with instruments using Agilent VEE. So, please 
install Agilent IO Libraries Suite 15.0 or greater after finishing this 
installation.

Click OK, the InstallShield® Wizard will check if Microsoft .NET 
Framework 3.5 is installed.
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3 If Microsoft .NET Framework 3.5 is not installed, following 
Question dialog box will appear to ask you to install it. Click Yes to 
install the Microsoft .NET Framework 3.5 immediately. After the 
installation, the Agilent VEE installation will continue 
automatically. Clicking No will abort the Agilent VEE installation.

If Microsoft .NET Framework 3.5 is installed, the InstallShield® 
Wizard will guide you to the next step directly to install your 
Agilent VEE selection in Step 1.

4 Click Next, when the following dialog box appears.

5 Accept the license agreement when the License Agreement dialog 
box appears, then click Next.
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6 Type your name, company name and product key when the 
Customer Information dialog box appears, then click Next. The 
product key is contained in the Agilent VEE Pro or Agilent VEE 
Express Product Key Certificate. 
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7 Click Next to accept the default settings when the following dialog 
box appears. 

8 Select Typical Setup when the Setup Type dialog box appears, then 
click Next to complete the installation.
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Launching Agilent VEE Pro or Agilent VEE Express
Go to All Programs > Agilent VEE Pro 9.0 > VEE Pro 9.0 or All Programs > Agilent 
VEE Express 9.0 > VEE Express 9.0 to launch Agilent VEE Pro or Agilent 
VEE Express.

You can access the demos, MATLAB examples (only available in 
Agilent VEE Pro) as well as sample programs via the Agilent VEE Pro 
or Agilent VEE Express welcome window. You may close the window 
after exploring it.

You can also open sample programs from the menu bar. To open a 
sample program, go to File > Open Example ...or Help > Open Example....

Output 
Window

Workspace

Program 
Explorer

Properties
Window

ToolBar

Status Bar

Menu Bar

Welcome 
Window
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Instrument Communication Tutorial
In this tutorial, we will connect to an instrument via the USB 
interface. Ensure that the Agilent IO Libraries Suite 15.0 is installed before 
proceeding. 

If you do not have a USB instrument, the tutorial for a GPIB 
instrument is similar from Step 3 onwards. 

The following screenshots are sourced from Agilent VEE Pro. Agilent 
VEE Express has similar screenshots.

1 Connect to an instrument via any USB port on your PC. Then, turn 
on the instrument. The Found New Hardware Wizard dialog box 
may appear. Just step through the wizard clicking Next.

2 When the Assign USB device alias dialog box appears, you must 
click OK to register the interface to your system. 
Agilent VEE Pro 9.0 & Agilent VEE Express 9.0 Quick Start Guide 9



VEE90_QSG.book  Page 10  Wednesday, August 20, 2008  3:11 PM
3 Launch Agilent VEE Pro or Agilent VEE Express, if you have not. 
Click the Instrument Manager button on the toolbar. 

4 The Instrument Manager tool window will appear. Click the Find 
Instruments button to automatically detect all instruments

connected to your PC. Click Yes if the Identify Instrument pop- up 
dialog box appears. This automatically identifies the instrument on 
the USB interface. In this example, an Agilent 34410A Digit 
Multimeter is present.

5 Right click newInstrument in the Instrument List panel. Then, 
choose Create Direct I/O Object in the opened context menu to place a 
Direct I/O object for the selected newinstrument on the workspace. 
This object allows you to send/receive commands to/from your 
instrument.
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6 Double- click the Direct I/O object's blue transaction bar to add a 
transaction to the Direct I/O object.

7 Type "*IDN?" (include the quotation marks) in the I/O Transaction 
dialog box as shown below. A list of available SCPI commands may 
appear while you are typing. You can choose one command as 
desired instead of typing the whole command. Click OK to proceed.

*IDN? is one of standard commands for programmable instruments 
(SCPI) command that queries the instrument for its identification 
string.

8 After sending the "*IDN?" query to the instrument, you need to 
read back its response. Double- click the text box of the 
newInstrument object to add a new transaction. This time, select 
the transaction to READ a STRING FORAT text to an output terminal 
named x. The output terminal x will be automatically created when 
you click OK.
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9 Select Display > AlphaNumeric and place an AlphaNumeric object on 
the workspace to the right of the Direct I/O object.

10 You will now connect the Direct I/O object to the AlphaNumeric 
object. Place the mouse cursor beside the Direct I/O output 
terminal and a square icon will appear. Left- click and drag a line 
to the input terminal of the AlphaNumeric object. Left- click again 
to complete the connection.

11 Run the program by clicking the Run button on the toolbar.
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12 The AlphaNumeric object will display the identification string 
output by the instrument as shown below.

13 To save your VEE code, select File > Save As and name the file as 
Tutorial 1.vee.
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Virtual Source Tutorial
In this tutorial, you will generate and display a waveform from a 
virtual source. No instrument is needed.

1 If you have an existing program in your Agilent VEE Pro or Agilent 
VEE Express workspace, select File > New. Then, select Device > 
Virtual Source > Function Generator and place a function generator 
object on the workspace.

2 By default, the function generator will generate a virtual cosine 
waveform at a frequency of 200 Hz, and an amplitude of 1. 
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3 Select Display > XY Trace and place an XY Trace object to the right of 
the function generator. 

4 Connect the function generator output terminal to the input 
terminal of the XY trace. Place the mouse cursor beside the 
function generator output terminal and a square icon will appear. 
Left- click and drag a line to the input terminal of the XY Trace 
object. Left- click again to complete the connection.

5 Click the Run button on the toolbar and you can see the 
cosine waveform displayed on the XY Trace object. 
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6 Select Display > Spectrum (Freq) > Magnitude Spectrum and place a 
Magnitude Spectrum object on the workspace below the XY Trace 
object

.

7 Connect a second line from the output of the function generator to 
the input of the Magnitude Spectrum object using the same 
left- click and drag method as described in Step 4.

8 Click the Run button and observe the magnitude spectrum 
display. As the waveform is a 200 Hz cosine, the magnitude 
spectrum displayed will be a vertical line at the frequency of 200 
Hz.
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9 Change the waveform function on the virtual function generator to 
a square waveform. 
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10 Click the Run button and observe the difference. Agilent VEE 
gives you the flexibility to analyze your signal source in multiple 
graph displays simultaneously. 

11 To save your VEE code, select File > Save As and name the file as 
Tutorial 2.vee
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Differences Between Agilent VEE Pro and Agilent VEE 
Express

The following table shows the differences between Agilent VEE Pro 
and Agilent VEE Express.

Agilent also provides Agilent VEE Student and Agilent Education 
versions for academic users.

Features Agilent VEE Pro Agilent VEE 
Express

Interfaces GPIB, LAN, 
RS- 232, VXI, PXI, 

SCXI

USB
(Agilent USB 

devices in 
LiveMode Only)

MatlabScript objects & MatlabScript 
engine

Creating RunTime version of Agilent 
VEE programs and secured version of 
Agilent VEE objects

Programmatic changing of instrument 
address

The Callable Server feature, i.e. calling 
Agilent VEE as an ActiveX Automation 
server

The Remote Function feature, i.e. 
importing a UserFunction that runs in 
another Agilent VEE process on a 
remote host computer

Other features
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Agilent VEE 9.0 New Features
Multithreading-- This feature can increase the performance of your system created 
with Agilent VEE. With this feature, you can easily create multiple threads in an 
Agilent VEE program to gain shorter execution time, faster response speed, and 
higher IO throughput. A new Execution Mode is also introduced along with the 
Multithreading feature. 

Multicore Programming-- This new feature provides you with the Multicore 
Programming capability. You can gain even higher performance for your multithread 
programs by allocating different threads to specified CPU cores if your computer has a 
multi-core CPU. 

SCPI Completion -- With this feature, you can easily choose a SCPI command from a 
list that appears while you are typing a SCPI command in the IO Transaction object. A 
description of the chosen SCPI command is also displayed. It saves your time spent 
searching in SCPI manuals and checking syntax errors dramatically. Moreover, you 
can even choose your own SCPI command file instead of using the default SCPI 
command file automatically selected by VEE. 

Private UserFunction -- Agilent VEE 9.0 provides a new type of UserFunction -- 
Private UserFunction to help you to modularize your VEE programs better and 
encapsulate your VEE programs for larger scale applications.

Conditional Breakpoint -- Conditional Breakpoint equips you with the capability to set 
conditions and hit count for a breakpoint and specify what to do when a breakpoint is 
hit, which gives you more control of the debugging process and higher efficiency.

Breakpoints Window -- The Breakpoints window allows you to explore and control all 
breakpoints in your VEE program. For example, you can activate or deactivate 
breakpoints as well as delete breakpoints in the Breakpoints window. 

Error Call Stack -- Use the Error Call Stack as an aid in debugging your VEE program. 
The Error Call Stack displays the UserObject or UserFunction where the error occurs. 
In addition, the Error Call Stack also shows the list or hierarchy of which UserObject 
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or UserFunction is invoking or calling the currently executing object where the error 
occurs.

Integrated Database Support -- This feature allows you to easily connect to any 
databases supported by ADO.NET, such as Microsoft Access, Microsoft SQL Server, 
Oracle, MySQL etc; you can store huge amounts of testing data in that database with 
a well structured format, and then retrieve them at anytime as needed to do analysis 
or testing. 

LXI Support -- All LXI instruments have a web interface that provides useful 
information about the instrument, a standard way to configure the LAN interface, and 
other features. Agilent VEE provides a easy way to open an LXI web interface of an 
instrument in a VEE built-in Web Browser. 

Enhanced Default Preferences -- Default Preferences dialog box is reorganized and 
enhanced to give you not only modern programming experience but also enhanced 
functionality. 

Enhanced Custom Menu Support -- Besides the text format, XML format is also 
supported in Agilent VEE 9.0. Two custom menu tools are also released with Agilent 
VEE 9.0 to help to edit your custom menu and convert custom menus from the old text 
format to the new XML format. 

New Toolbars for VEE Object-- A new set of icon as well as several new toolbars are 
assigned to some frequently used VEE objects. It is easier for you to pick a VEE object 
from these toolbars than from main menu. 

Support for NaN and Infinity -- Agilent VEE 9.0 adds support for NaN and +/-Infinity 
for data type Real64 and Real32 and introduces four built-in functions: isNaN, 
isInfinity, isNegativeInfinity, isPositiveInfinity. VEE can convert NaN, Infinity from 
number to string and vice versa and allow NaN and Infinity in .NET and MATLAB to 
output to VEE and vice versa.

New Examples -- New Agilent VEE examples for some commonly used VEE objects 
are added to help you to easily kickstart your learning.
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Agilent Connectivity Products

Agilent provides a complete range of high performance and highly 
reliable products to connect from your PC to your instruments. These 
include networked USB hub, LAN/GPIB gateway, PCI GPIB, USB/GPIB 
and USB/RS232 interfaces. For more information on Agilent 
connectivity products, visit www.agilent.com/find/io.

Agilent Support, Services and Assistance
With Agilent VEE Pro & Agilent VEE Express, you have access to 
Agilent’s worldwide resources for start- up assistance, training classes, 
and update services. As part of the purchase of any Agilent VEE 
product you are entitled to receive technical support free of charge. 
There is no need to register. 

Additional consulting services are available from Agilent. There are 
currently over 30 companies available in North America, Europe, 
Middle East and Asia to help you develop your Agilent VEE solution.

Sign up for the Agilent VEE electronic users group at 
http://www.agilent.com/find/vrf, and get help on using Agilent VEE 
from experts around the world.
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Appendix
Agilent VEE Pro Help is now available in other languages. To use 
online help file in other languages, please 

1 Download localized online help from www.Agilent.com/find/vee.

2 Save downloaded files into the installation directory of Agilent 
VEE. Generally, it is C:\Program Files\Agilent\VEE Pro 9.0. Please do 
not change the name of the downloaded online help files.

3 Open Agilent VEE.

4 Open the Default Preferences (File => Default Preferences). Choose 
the help file language as you need under the Help tab.

5 Click OK to close the Default Preferences dialog box.

Microsoft is a U.S. registered trademark of Microsoft Corporation.
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